概述

  • EP01是CORIGHT推出的USB高速编程器。
  • EP01支持24、25、93 EEPROM以及SPI FLASH。
  • EP01支持滚动码芯片的烧录。
  • EP01安全、高速、便携。

[产品特性]
[系统需求]
[历史版本]
[版权信息]

版权所有 © 2010-2012 CORIGHT.COM 保留全部权利.


EP01 产品特性

  • 外观小巧、便携。
  • 内置自恢复保险丝，为设备提供持续保护。
  • USB 2.0接口，速度高达12Mbps。
  • 支持HCS系列滚动码芯片的编程操作。
  • 支持24 EEPROM、25 EEPROM、93 EEPROM、SPI FLASH等系列的存储芯片。
  • 支持软件及固件的自动检测升级，更多支持芯片型号持续添加。
  • 软件支持多国语言，用户可根据需要自定义界面语言。
  • 友好的缓存区编辑窗口。
  • 支持Windows 2000、Windows XP、Windows Vista、Windows 7、Windows 8。

[概述]


系统需求

最小的系统需求:

  • 操作系统: Win2000/XP/Vista/7/8。
  • 分辨率：1024*768。
  • USB1.0标准的通用串行总线接口。
  • CD-ROM光驱。
  • 64M的RAM。
  • 硬盘至少10M剩余空间。

[概述]


支持芯片列表

*************************滚动码芯片*************************
HCS301; HCS300; HCS201; HCS200; HCS101;

*************************24 EEPROM*************************
ATMEL: AT24C01; AT24C01A; AT24C01B; AT24C02; AT24C02A; AT24C02B; AT24C04; AT24C04A; AT24C04B; AT24C08; AT24C08A; AT24C08B; AT24C16; AT24C16A; AT24C16B; AT24C32; AT24C32A; AT24C32B; AT24C64; AT24C64A; AT24C64B; AT24C128; AT24C128A; AT24C128B; AT24C256; AT24C256A; AT24C256B; AT24C512; AT24C512A; AT24C512B; AT24C1024; AT24C1024A; AT24C1024B;
CATALYST: CAT24C01; CAT24C02; CAT24C04; CAT24C08; CAT24C16; CAT24C32; CAT24C64; CAT24C128; CAT24C256; CAT24C512; CAT24C1024;
CORIGHT: 24C01; 24C02; 24C04; 24C08; 24C16; 24C32; 24C64; 24C128; 24C256; 24C512; 24C1024;
FAIRCHILD: FM24C01; FM24C02; FM24C03; FM24C04; FM24C05; FM24C08; FM24C09; FM24C16; FM24C17; FM24C32; FM24C64; FM24C128; FM24C256; FM24C512; FM24C1024;
HOLTEK: HT24C01; HT24LC01; HT24C02; HT24LC02; HT24C04; HT24LC04; HT24C08; HT24LC08; HT24C16; HT24LC16; HT24C32; HT24LC32; HT24C64; HT24LC64; HT24C128; HT24LC128; HT24C256; HT24LC256; HT24C512; HT24C1024;
ISSI: IS24C01; IS24C02; IS24C04; IS24C08; IS24C16; IS24C32; IS24C64; IS24C128; IS24C256; IS24C512; IS24C1024;
MICROCHIP: 24AA00; 24LC00; 24FC00; 24AA01; 24LC01; 24FC01; 24AA02; 24LC02; 24FC02; 24AA04; 24LC04; 24FC04; 24AA08; 24LC08; 24FC08; 24AA16; 24LC16; 24FC16; 24AA32; 24LC32; 24FC32; 24AA64; 24LC64; 24FC64; 24AA128; 24LC128; 24FC128; 24AA256; 24LC256; 24FC256; 24AA512; 24LC512; 24FC512; 24AA1026; 24LC1026; 24FC1026;
NSC: 24C02; 24C02L; 24C64;
NXP: PCA24S08A;
RAMTRON: FM24C04A; FM24CL04; FM24C16A; FM24CL16; FM24C64; FM24CL64; FM24C256; FM24CL256; FM24C512;
ROHM: BR24C01; BR24L01; BR24C02; BR24L02; BR24C04; BR24L04; BR24C08; BR24L08; BR24C16; BR24L16; BR24C32; BR24L32; BR24C64; BR24L64;
ST: ST24C01; ST24C02; ST24C04; ST24C08; ST24C16; ST24C32; ST24C64;
XICOR: ST24C01; ST24C02; ST24C04; ST24C08; ST24C16;

*************************25 EEPROM*************************
ATMEL: AT25010; AT25020; AT25040; AT25080; AT25160; AT25320; AT25640; AT25128; AT25256; AT25512;
CATALYST: CAT25C01; CAT25C01P; CAT25C01S; CAT25C01U; CAT25C02P; CAT25C02S; CAT25C02U; CAT25C03P; CAT25C03S; CAT25C03U; CAT25C04P; CAT25C04S; CAT25C04U; CAT25C05P; CAT25C05S; CAT25C05U; CAT25C08P; CAT25C08S; CAT25C08U; CAT25C09P; CAT25C09S; CAT25C09U; CAT25C16P; CAT25C16S; CAT25C16U; CAT25C17P; CAT25C17S; CAT25C17U; CAT25C32P; CAT25C32S; CAT25C33P; CAT25C33S; CAT25C64P; CAT25C64S; CAT25C65P; CAT25C65S; CAT25C128P; CAT25C128S; CAT25C256P; CAT25C256S;
CORIGHT: 25C01; 25C01; 25C040; 25C080; 25C160; 25C320; 25C640; 25C128; 25C256;
MICROCHIP: 25C040; 25C080; 25C160; 25C320; 25C640; 25LC040; 25LC080; 25LC160; 25LC320; 25LC640; 25LC128; 25LC256; 25AA040; 25AA080; 25AA160; 25AA320; 25AA640; 25AA128; 25AA256;
RAMTRON: FM25C160; FM25640; FM25CL64;
ST: ST25C01; ST25C02; ST25C04; ST25C08; ST25C16; ST25W01; ST25W02; ST25W04; ST25W08; ST25W16; M95010; M95020; M95040; M95080; M95160; M95320; M95640; M95128; M95256; M95512;
TI: TI2532; TI2532A; TI2564;
XICOR: X25010; X25020; X25040; X25080; X25160; X25320; X25640; X25128; X25256; X25512;

*************************93 EEPROM*************************
ACE: ACE93C46-16bit; ACE93C46-8bit;
AKM: AK93C45A; AK93C55A; AK93C65A; AK93C75A;
ATC: ATC93C46-16bit; ATC93C46-8bit; ATC93C56-16bit; ATC93C56-8bit; ATC93C66-16bit; ATC93C66-8bit; ATC93C86-16bit; ATC93C86-8bit;
ATMEL: 93C46-16bit; 93C46-8bit; 93C56-16bit; 93C56-8bit; 93C66-16bit; 93C66-8bit; 93C76-16bit; 93C76-8bit; 93C86-16bit; 93C86-8bit;
CATALYST: CAT93C46-16bit; CAT93C46-8bit; CAT93C56-16bit; CAT93C56-8bit; CAT93C57-16bit; CAT93C57-8bit; CAT93C66-16bit; CAT93C66-8bit; CAT93C86-16bit; CAT93C86-8bit;
CORIGHT: 93C06; 93C46-16bit; 93C46-8bit; 93C56-16bit; 93C56-8bit; 93C66-16bit; 93C66-8bit; 93C76-16bit; 93C76-8bit; 93C86-16bit; 93C86-8bit;
EXEL: XL93C06; XL93C46; XL93CS46; XL93LC46; XL93C56; XL93LC56; XL93C66; XL93LC66;
FAIRCHILD: FM93C06; FM93C46; FM93C46A-16bit; FM93C46A-8bit; FM93C56; FM93C56A-16bit; FM93C56A-8bit; FM93C66; FM93C66A-16bit; FM93C66A-8bit; FM93C86A-16bit; FM93C86A-8bit;
HOLTEK: HT93LC46-16bit; HT93LC46-8bit; HT93LC56-16bit; HT93LC56-8bit; HT93LC66-16bit; HT93LC66-8bit;
ICT: ICT93C46-16bit; ICT93C46-8bit; ICT93C56-16bit; ICT93C56-8bit; ICT93C66-16bit; ICT93C66-8bit;
ISSI: IS93C46; IS93C46A-16bit; IS93C46A-8bit; IS93C56; IS93C56A-16bit; IS93C56A-8bit; IS93C66; IS93C66A-16bit; IS93C66A-8bit; IS93C76A-16bit; IS93C76A-8bit; IS93C86A-16bit; IS93C86A-8bit;
MICROCHIP: 93C06; 93C46-16bit; 93C46-8bit; 93C56-16bit; 93C56-8bit; 93C66-16bit; 93C66-8bit; 93C76-16bit; 93C76-8bit; 93C86-16bit; 93C86-8bit; 93C46B; 93C46A; 93C56B; 93C56A; 93C66B; 93C66A; 93LC46-16bit; 93LC46-8bit; 93LC56-16bit; 93LC56-8bit; 93LC66-16bit; 93LC66-8bit; 93LC76-16bit; 93LC76-8bit; 93LC86-16bit; 93LC86-8bit; 93LC46B; 93LC46A; 93LC56B; 93LC56A; 93LC66B; 93LC66A; 93AA46-16bit; 93AA46-8bit; 93AA56-16bit; 93AA56-8bit; 93AA66-16bit; 93AA66-8bit; 93AA76-16bit; 93AA76-8bit; 93AA86-16bit; 93AA86-8bit;
NSC: 93C06; 93C46; 93C56; 93C66; 93C86; 93CS06; 93CS46; 93CS56; 93CS66; 93CS86;
ROHM: BR93LC46; BR93LC56; BR93LC66; BR93LC46RF; BR93LC56RF; BR93LC66RF;
SEIKO: S-93C46A; S-93C56A; S-93C66A;
ST: ST93C06; ST93C46; ST93C56; ST93C66; M93S46; M93S56; M93S66; M93S46R; M93S56R; M93S66R; M93S46W; M93S56W; M93S66W;

*************************SPI FLASH*************************
ALTERA: EPCS1; EPCS4; EPCS16; EPCS64; EPCS128;
AMIC: A25L512; A25L010; A25L020; A25L040; A25L080; A25L016; A25L032; A25L05PT; A25L05PU; A25L10PT; A25L10PU; A25L20PT; A25L20PU; A25L40P; A25L80P; A25L16PT; A25L16PU;
ATMEL: AT25F512; AT25F512A; AT25F512B; AT25F1024; AT25F1024A; AT25F2048; AT25F4096; AT25FS010; AT25FS020; AT25FS040; AT26F004; AT25DF021; AT25DF041A; AT26DF081A; AT25DF161; AT26DF161; AT26DF161A; AT25DF321; AT25DF321A; AT26DF321; AT25DF641;
CORIGHT: 25P05; 25P10; 25P20; 25P40; 25P80; 25P16; 25P32; 25P64; 25P128;
EON: EN25P05; EN25B05; EN25B05T; EN25P10; EN25B10; EN25B10T; EN25P20; EN25B20; EN25B20T; EN25P40; EN25B40; EN25B40T; EN25P80; EN25B80; EN25B80T; EN25P16; EN25B16; EN25B16T; EN25P32; EN25B32; EN25B32T; EN25P64; EN25B64; EN25B64T; EN25F05; EN25LF05; EN25F10; EN25LF10; EN25F20; EN25LF20; EN25F40; EN25LF40; EN25F80; EN25F16; EN25F32; EN25F64; EN25F128; EN25Q80A; EN25Q16; EN25Q16A; EN25Q32A; EN25Q32B; EN25Q64; EN25Q128; EN25D10; EN25D20; EN25D40; EN25D80; EN25D16; EN25T80; EN25T16;
ESMT: F25L004A; F25L004AT; F25L04UA; F25L008A; F25L008AT; F25L08PA; F25L016A; F25L016AT; F25L16PA; F25L32PA; F25L32QA;
EXCELSEMI: ES25P10; ES25P20; ES25P40; ES25P80; ES25P16; ES25P32; ES25M40; ES25M40A; ES25M80; ES25M80A; ES25M16; ES25M16A;
GIGADEVICE: GD25Q512; GD25Q10; GD25Q20B; GD25Q40B; GD25Q80B; GD25Q16B; GD25Q32B; GD25Q64B; GD25Q128B; GD25Q128C;
MICRON: M25P05; M25P10; M25P20; M25P40; M25P80; M25P16; M25P32; M25P64; M25P128; N25Q032; N25Q064; N25Q128; N25Q128A; N25Q256A;
MXIC: MX25L512; MX25V512; MX25L1005; MX25L2005; MX25L4005A; MX25V4005; MX25L8005; MX25V8005; MX25L1605D; MX25L1606E; MX25L1635D; MX25L1633E; MX25L3205D; MX25L3206E; MX25L3225D; MX25L3235D; MX25L3237D; MX25L6405D; MX25L6406E; MX25L12805D; MX25L12835E; MX25L12845E; MX25L25635E; MX25L25735E; MX25V4035; MX25V8035;
NEXFLASH: NX25P10; NX25P20; NX25P40; NX25P80; NX25P16; NX25P32;
PMC: PM25LV512; PM25LV010; PM25LV020; PM25LV040; PM25LV080B; PM25LV016B;
SAIFUN: SA25F005; SA25F010; SA25F020; SA25F040; SA25F080; SA25F160; SA25F320;
SPANSION: S25FL004A; S25FL008A; S25FL016A; S25FL032A; S25FL064A; S25FL128S; S25FL256S; S25FL512S;
SST: SST25VF512; SST25VF010; SST25VF020; SST25VF040; SST25VF080; SST25VF512A; SST25VF010A; SST25VF020A; SST25VF040A; SST25VF080A; SST25LF512A; SST25LF010A; SST25LF020A; SST25LF040A; SST25LF080A; SST25VF020B; SST25VF040B; SST25VF080B; SST25VF016B; SST25VF032B; SST25VF064C;
ST: M25P05A; M25P10A; M25P20A; M25P40A; M25P80A; M25P05; M25P10; M25P20; M25P40; M25P80; M25P16; M25P32; M25P64; M25P128; M25P05A; M25P10A; M25PE10; M25PE20; M25PE40; M25PE80; M25PE16; M25PX80; M25PX16; M25PX32; M25PX64;
WINBOND: W25P10; W25X10; W25X10A; W25X10AL; W25X10L; W25P20; W25X20; W25X20A; W25X20AL; W25X20L; W25P40; W25X40; W25X40A; W25X40AL; W25X40L; W25P80; W25X80; W25X80A; W25X80AL; W25X80L; W25P16; W25X16; W25P32; W25X32; W25X64; W25Q20; W25Q40; W25Q80; W25Q16; W25Q32; W25Q64; W25Q128; W25Q256;


EP01 软件《最终用户许可协议》

请仔细阅读以下使用许可，如果您不同意以下任何一点，请立即停止使用此软件。

上海CORIGHT有限公司，将本软件程序的最终使用权限授予您。但您必须向本公司作以下保证：

    本《用户许可协议》（以下称《协议》）是您（个人或单一机构团体）与上述 EP01 软件（以下称“软件”或“软件产品”）版权所有人上海CORIGHT有限公司（以下称“CORIGHT”）之间的法律协议。在您使用本软件产品之前,请务必阅读此《协议》，任何与《协议》有关的软件、电子文文件等都应是按本协议的条款而授予您的，同时本《协议》亦适用于任何有关本软件产品的后期发行和升级。您一旦安装、复制、下裁、访问或以其它方式使用本软件产品，即表示您同意接受本《协议》各项条款的约束。如您不同意本《协议》的条款，那么，版权所有人CORIGHT则不予将本软件产品的使用权授予您。在这种情况下，您不得使用、复制或传播本软件产品。

    软件产品许可协议
本软件产品受著作权法及国际著作权条约和其它知识产权法及条约的保护。本软件产品只许可使用，而不出售。不收取任何费用，不得用于商业目的的活动之中。

1．许可证的授予。本《协议》授予您下列权利：

A. 安装和使用：
您可安装无限制数量的本软件产品来使用。

B. 复制、分发和传播：
您可以复制、分发和传播无限制数量的软件产品，但您必须保证每一份复制、分发和传播都必须是完整和真实的，包括所有有关本软件产品的软件、电子文文件，版权和商标宣言，亦包括本协议。
本软件可以独立分发亦可随同其它软件一起分发，但如因此而引起任何问题，版权人将不予承担任何责任。

2．其它权利和限制说明：

A. 禁止反向工程、反向编译和反向汇编：
您不得对本软件产品进行反向工程、反向编译和反向汇编。除非适用法律明文允许上述活动，否则您必须遵守此协议限制。

B. 组件的分隔：
本软件产品是被当成一个单一产品而被授予许可使用，不得将各个部分分开用于任何目的行动。

C. 软件产品转让：
在不保留任何副本，您可以将本“软件产品”（包括所有组成部分零件、媒介和印刷材料、任何更新版本、本《协议》等）全部转让，并且受让人接受本《协议》的各项条件下，您可永久转让您在本《协议》下的所有权利。
如果本“软件产品”为更新本，转让时必须包括本“软件产品”所有前版本。

D. 终止：
如您未遵守本《协议》的各项条件，在不损害其它权利的情况下，版权人可将本《协议》终止。如发生此种情况，则您必须销毁“软件产品”及其各部分的所有副本。

E. 商标：
本《协议》不授予您由版权人CORIGHT所拥有的任何商标或服务商标有关的任何权利。

F. 免费使用：
本软件产品只许可免费使用，不得出售，不收取任何费用，不得用于商业目的的活动之中。
本软件产品不能用于销售或随同旨在获益的软件产品或产品包一起分发。但本软件可包含在任何免费或非赢利性的软件产品或产品包里。同时您必须保证所分发的软件包含全部文件，并且未作任何修改。

G. 个别授权：
如有任何组织或个人利用本软件以任何方式为公众服务并同时满足其自身特定目的而分发、复制和传播本软件产品，均须得到版权人授权同意后方可进行，否则视为侵权。

3. 版权：

本软件产品(包括但不限于本软件产品中所含的任何图象、照片、动画、文字和附加程序(applets))、随附的印刷材料、及本软件产品的任何副本的一切所有权和知识产权，均由版权人CORIGHT拥有。通过使用本“软件产品”可访问的内容的一切所有权和知识产权均属于各自内容的所有者拥有并可能受适用著作权或其它知识产权法律和条约的保护。本《协议》不授予您使用这些内容的权利。

4. 保证：

本软件版权人CORIGHT特此申明对本软件产品之使用不提供任何保证。版权人将不对任何用户保证本软件产品的适用性，不保证无故障产生；亦不对任何用户使用此软件所遭遇到的任何理论上的或实际上的损失承担负责。

5.免费下载

本软件产品免费提供给您使用。您可在互联网(http://www.coright.com)上免费下载，本公司不收取任何费用。本软件产品版权人CORIGHT拥有最终解释权。


程序界面

EP01具有友好的用户界面，菜单、工具栏简洁易用，软件界面如下：

EP01的工具栏：

  • 打开: 加载文件到缓冲区。
  • 保存: 保存缓冲区到文件。
  • 填充: 填充缓冲区指定数据段内容为某一数值。
  • 交换: 交换缓冲区中相邻两字节数据。
  • 自动: 自动完成编程操作。
  • 擦除: 擦除芯片内部数据（置1）。
  • 写入: 将缓冲区中数据写入芯片。
  • 读出: 读取芯片数据到缓冲区。
  • 校验: 比较芯片和缓冲区中数据是否相同。
  • 管脚: 查看当前芯片的管脚配置。
  • 设备: 查看设备型号及版本信息。
  • 关于: 显示编程器软件版本信息。


选项

自动编程：

  • 通过“添加”、“删除”、“清空”以及鼠标双击操作编辑“自动编程”内容。
  • 支持重复操作。

编辑：

  • 列数：数据显示列数。
  • 段长度：数据列分组长度。
  • 显示地址：是否显示地址；地址显示方式。
  • 数据：数据显示方式。
  • 显示ASCII：是否显示字符区。
  • 显示UNICODE：是否显示UNICODE字符（ASCII选中状态下可用）。
  • 前景色：各个区域字体显示颜色。
  • 背景色：各个区域背景颜色。
  • 默认值：恢复本页设定值到默认值。


滚动码

滚动码设定界面如下：

  • 根据选择芯片不同设定界面会有所改变。
  • 支持全部四种编码方式Simple、Normal、Secure XOR、Secure Decrypt。
  • 内部24字节数据完全可以自行修改，满足所有设定需求。
  • 滚动码芯片为“只写”芯片，所以EP01只提供“写入”功能。
  • 单次写入后会即刻校验写入数据，并给出结果。


管脚配置

管脚配置界面如下：

  • 查看当前芯片的管脚配置。
  • 建议更换芯片前检查管脚配置是否正确，以免导致读写失败。


设备信息

设备信息界面如下：

  • 设备型号：显示当前设备型号。
  • 设备版本：显示当前设备固件版本。


语言设定

  • EP01支持多国语言（最多1000个国家语言）。
  • EP01默认提供“英语”、“简体中文”、“繁体中文”三种语言。
  • 用户可根据需要自行翻译来定制或增加语言。

自定义语言：

  • 打开位于EP01程序安装目录下Language文件夹内对应语言文件。
  • 修改相应文字。
  • 保存并重启EP01软件。

新增语言：

  • 进入EP01程序安装目录下Language文件夹。
  • 复制任一已有语言文件并重命名。
  • 编辑新的语言文件。
  • 设定新语言文件中[Setting]段的Language值为新增加语言名称。


检查更新

检查软件更新：

  • 选择“检查软件”；
  • 点击“检查更新”，根据相应提示进行操作即可。

检查固件更新：

  • 选择“检查固件”；
  • 点击“检查更新”，根据相应提示保存最新版本固件升级程序至本地磁盘；
  • 通过“升级固件”对设备进行升级。

在线获取最新版本应用程序：

  • 通过浏览器直接访问：http://www.coright.com/products


升级固件

  • 通过“检查更新”获取最新版本固件升级程序。
  • 依次点击菜单“帮助”、“升级固件”。
  • 选择固件升级程序，根据提示完成固件升级操作。


自动编程

  • 自动完成“擦除”、“写入”、“校验”、“读取”等组合操作。
  • 具体操作组合可通过“选项”进行修改。


擦除

  • 擦除芯片内部数据（置1）。
  • 部分SPI FLASH芯片写入数据前必须先执行“擦除”操作。
  • 部分不支持擦除操作的芯片被选中时，“擦除”选项将被禁用。


写入

  • 将缓冲区中数据写入芯片。
  • 部分SPI FLASH芯片写入数据前必须先执行“擦除”操作。


读出

擦除

  • 读取芯片数据到缓冲区。
  • 部分不支持读操作的芯片（HCS系列）被选中时，“读出”选项将被禁用。


校验

  • 比较芯片和缓冲区中数据是否相同。
  • 部分不支持校验操作的芯片（HCS系列）被选中时，“校验”选项将被禁用。


填充

填充界面如下：

  • 填充缓冲区指定数据段内容为某一数值。
  • EP01填充操作具备自动计算起始地址及长度的功能。
  • 没有选中任何数据：地址为0，长度自动填充为缓冲区长度。
  • 如果有选中数据：地址为选中数据起始位置，长度为所选数据长度。


常见问题

1.写入数据失败
(1)写数据前检查芯片型号及管脚配置是否正确。
(2)部分SPI FLASH芯片，写入数据前须先擦除。
(3)存储芯片可能已经损坏。
(4)编程器异常，升级最新版本软件及固件。


联系我们

如果您在使用中遇到问题或者您对软件有什么好的建议，请通过下面的方式与我们联系:

通过我们的网站：
http://www.coright.com/

通过E-mail：
sales@coright.com


历史版本

Version 1.0.0.6:

  • 增加支持芯片型号。
  • 修正已知BUG。

Version 1.0.0.5:

  • 增加支持芯片型号。

Version 1.0.0.4:

  • 修正部分24芯片写入错误。

Version 1.0.0.3:

  • 增加支持芯片型号。

Version 1.0.0.2:

  • 修正SST FLASH芯片写入错误。

Version 1.0.0.1:

  • 初始版本。
  • 可定制“自动编程”。
  • 芯片选择界面。
  • 24、25、93EEPROM。
  • SPI FLASH。
  • 滚动码烧录。

[概述]